Creating Cards Guide

From Arcmage Wiki
Jump to: navigation, search

Getting started

To create your own cards, first of all get an account on our cards database. Once logged in you can create your own cards.

Card text style guide

When working on cards, there are some general style guidelines that should be followed. Don't worry too much when a card has draft status - these rules are there to make the finished product cohesive.

  • General
    • Every sentence should be ended with a period
    • Fragments, such as keywords, should not end with a period
    • Use numerals for numbers, instead of spelling them out
    • Emphasize target words e.g. I, city, army
    • Use quotes and italic for flavor
    • Use two line card names for Creatures/Cities when the card name starts overlapping to much with the artwork
  • Keyword abilities
    • Place before more specific card abilities
    • Bold and italicize
    • Define if there is one and space to define it. This is left to the card creator's discretion
    • Bold and Italicize the definition
  • Subtypes
    • Every card should have a subtype
    • Capitalize the first letter
    • Bold and italicize
  • Drop caps should follow these guidelines:
    • Only use when its on the first line (so not in combo with keywords)
    • Only use when there are at least two lines.


Uploading Card Artwork guide

First thing to do is find a matching piece of artwork in our repository and check if it is unused by any other arcmage card.

Use gimp to prepare the png file

  • Set/check the dpi setting:
    • Image > Print Size : Set 600 dpi
  • Cropping
    • Image > Autocrop
  • Scaling
    • Image > Scale Image : keep aspect ratio, and I usually set the height to 1220
  • Centering
    • Image > Canvas Size : do not keep aspect ratio
      • For creatures/cities use 1535 width by 1266 height,
      • For events/magic/enchantments use 1535 width by 1214 height
      • If you want the image to be in the frame bounds, then the X offset is 70.
      • The Y offset is always set to the maximum.
  • Shadow
    • Filters > Light and Shadow > Drop Shadow
      • Offset X: 4, Offset Y: 4, Blur Radious: 15, Color: black, Opacity: 60, Allow Resizing (false, uncheck)
  • Export
    • File > Export as ... (select png)

Uploading to the card database

At the card's edit page, select Browse, point to the exported png file. Then click the 'Upload' button (should appear next to the 'Browse' button).

You'll have to change something e.g. loyalty, and hit save before it uses the new artwork (I should fix that). The result should show rather quick, the rasterized versions (png, jpeg, pdf's) are created in the background and might take a min or two.

Please do not forget to fill in the Artist!

All done!